Start a new topic

Banks / Programs frozen with Ableton / Midi


Have been using Emu with Ableton to run lights for my band's live show. I'm sending midi to control program and bank changes and using automation lanes and the EMU VST plugin to control the dimmers on individual light fixtures.

I'm currently experiencing an issue where EMU is getting stuck on specific scenes / banks despite appearing to be receiving the right information for programme and bank changes via midi. 

What I mean by this is that when I start playback for a specific song, EMU will briefly (like milliseconds) load the correct programme / bank and then immediately revert back to the bank it is on before. There isn't any logic as to what programme/bank it gets stuck on and this issue actually affects using the EMU interface as well - i.e. While Ableton is open I'm blocked from changing bank or programme in the EMU desktop app itself.

Has anyone experienced this issue before or could provide any support? I'm honestly running out of ideas / willpower on what this could be so any help appreciated. Happy to give more info if helpful. 



I believe this is been resolved starting from I am on the latest Beta which is now and don't have this issue. So update your EMU to the latest Beta and if you will have something not expected - submit a ticket.

Any update on a patch for this problem? Experiencing this now and it’s pretty frustrating.

Thanks for keeping us updated, hope you're good now. However downgrading may cause some other issues (if we look to the list of the newer updates and their descriptions). 

Posting a lil update as I raised a ticket with the Entec support team and they've solved the issue. The problem is the result of a bug in recent updates. Anyone else experiencing the same issue should revert to and the issue should be fixed. It has been for me at least. 

Not entirely happy that I've wasted hours of my life trying to resolve this issue that is the result of a software bug the Emu / Entec don't appear to have publicised but oh well....


I tried the latest update and have checked the midi loop issue.

For midi:

  • IAC driver (bus 1) is my midi device. Track & Remote is checked for both in and out.
  • I have two midi tracks, one for bank selection and one for programme selection. These are set to 'no input' and outputting on channels 15 & 16 respectively.
  • I have a third midi track which is connected to the emu VST3 plugin and I've mapped dimmers to faders.This has no input and is set to output in the 'main'.
  • I have a couple of other midi tracks which, 1 is a stop track to automate stopping at the end of the songs (no input, out to ch1), and finally one track to program patch changes for our guitarist's modelling amp outputting on a different device altogher. 
I've checked and there's nothing that indicates I have a feedback loop.

The problem actually appears to be linked to the vst 3 plugin. When i disable the plugin or delete the track that it's running on, the midi program changes work fine and I can move between programs / banks in the EMU UI, no problem. 

Any thoughts on this greatly appreciated.

I have two thoughts:

1) Try update EMU for the latest BETA version (this is fair if you have the same issues even without Ableton, i.e. when changing banks manually):


2) Midi Loop issue. It is pretty common user's mistake. When in a DAW users choose for input and output the same channel. This leads to looping and inadequate work and even freezes. 

Login or Signup to post a comment